Topic – Resurrecting Konica Hexar AF from the dead

I used the hexar on my vacation in the US and it performed flawlessly there despite 50 C heat in Las Vegas and Hoover Dam. This is a camera that is easy to get spoilt by. It is small, quick, exposes perfectly, is sharp and is silent. No wonder I have come to enjoy it!

But… would you believe it! When I grabbed the Hexar for a walk the other day it refused to work! It did not react to anything! At all! I have read about this dreaded symptom. The prospects were grim!

But since “its only electronics these days” I had a peek inside it and found the culprit! It appears that the vias on the flexible circuit board apparently can develop breaks. In my case a via for the positive supply did not work.

The circuit board is populated with surface mount devices, SMDs, and since my nearsightedness has not left me yet, I have no problems soldering the little buggers even without a microscope.  In this case it was a simpler case of following the traces on the double sided board but still my eyes and an Armytek head lamp helped a lot. And the problem was not SMD-related at all.

hexrep

An overview of the bottom PCB with the camera’s bottom plate removed (in fact I removed MUCH more just do analyze the problem, but this is where the problem was). The battery compartment has a rechargeable battery for testing here (remove when soldering:). The battery current is fed directly to a filter capacitor (the rightmost above) before going to the motor drive ICs to the right. The LB8620 contains two motor drives. There are two of these chips, the second is just discernible to the far right. The two pins in each corner of the chip are ground and Vcc is fed on pin 3 (3rd from above left).

hexrep (2)

Here is a detail of the PCB.  The two very small cisterns are the two 100uF/10V capacitors. The leftmost vertical trace is the positive supply running on the upper side of the PCB to the right capacitor’s positive pin, situated to the right of the blue capacitor on the PCB’s under side, not visible in the picture above. From this pin the supply changes side to the lower side of the PCB and runs to the motor drive circuitry, among other things. It was this through-hole that did not work. 

With a temp controlled solder iron I removed the right cap altogether and found some green corrosion on the pins and some smudge on the PCB itself. Isopropanol cleansed the areas but a simple resoldering did not alleviate the problem.  Perhaps the cap is giving up slowly? Resistance measurement of it showed a increasing resistance as it should.

One could hope that solder  and reheat on the pin would connect the upper and lower side of the PCB. Not so in this case. So I decided to do a jumper instead of relying on the PCB. The jumper is the overly red wire soldered to the SOT-89 type IC (marked OK14). From here it runs to the under side of the PCB just beside the plastic little “screw tower”, it is then soldered to the right capacitor’s positive pin on the underside of the PCB. From there on it is on its own and the PCB seems to be fine.

I used just over 300 degrees  (Celcius of course, we’re civilized) on the solder iron but also tested 350 degrees on a bit of the unused flexible PCB. It turns out that the PCB plastic is quite tolerant to heat so that no extra precautions seemed to be necessary. Of course one should not be overly slow when heating the capacitor pin but there is no need for split second timing either. In my case a 2-3 second heating was enough.

Looking up the various SMDs, and specially the CPU chip, I found no indication that 6.5 V would be dangerous, most components have an “Absolute maximum rating” of 7 V. Note that the data sheet “Absolute maximum”-figures indicate where no damage will happen to the component – no actual function is promised though. I have previously noted that 6.4-6.5 V is some kind of maximum voltage where the camera will run, above this the LCD acts up. Better not charge the battery with more than 6 volts then…

After this modification the camera reacts normally in all aspects and sounds OK too. I will have to do a short test roll just to check the the focussing still is calibrated.

Update: Recently one of my blog readers sent me his dead Hexar for analysis. He had tried to find service for it but due to the age of the  electronics involved and lack of replacement parts no one was willing to even look at it. I accepted the Hexar with the condition that I could guarantee nothing but I would have a peek inside and have a go at it. Unfortunately the above solution was not the problem as somehow the CPU did not boot in this camera. After making it tick again I pro-actively also resoldered the caps as per above and it has been functioning ever since. So dead Hexars are not necessarily  paper weights!

Advertisements
Gallery | This entry was posted in All, Topics. Bookmark the permalink.

35 Responses to Topic – Resurrecting Konica Hexar AF from the dead

  1. Kay says:

    Well done!
    Unfortunately mine is dead too and the problem is different from yours.
    Do you had resources to figure out how to get deeper into the camera? I can’t figure out how to get the front cover off the camera for instance.

    Greets
    Kay

    • Jabcam says:

      I am sorry to hear about your Hexar. When taking it apart I had no resources except my nearsightedness which helped to see the very small parts and the copper traces. The front cover goes off after loosening screws just around the lens (pry away the wedge formed leather a centimeter) and along the battery handle (pry along the whole vertical part). A total of 4 (or was it 6?) screws altogether.

      What is the symptom in your camera?

      Best of luck!

      • Kay says:

        Thanks for the reply. Mine says nothing at all when switching on. it wasn’t used for a year or so. It’s not corrosion on the power switch or battery pins.
        I found these screws and had a look around. The VCC is available on pin 3 of the motor driver so I guess it has to be different source of problem.
        Do you happen to know where the black/red-power cable in your pic comes from? because there is now voltage on those pins. It should be, or no?

  2. Jabcam says:

    Kay, the red/black cable provide the main Vcc and GND from the battery to the plastic circuit board. IIRC they come directly from the battery contacts, but there was a soldered point somewhere also, probably just another distribution point to the upper PCB (the one with the top switches on it). There should definitely be full battery voltage between them. Strange if not, while you have Vcc on the motor bridges. I wish there were a published schematic on it, things had been soooo much easier then.

    If the display is dead then perhaps the processor does not boot (usually through a simple RC-net to /RST on the chip). Also if the power is broken to the upper PCB then all will be blank in the display too.

    Another idea (grasping straws here) is that if some sensor has lost power/connection the processor halts during an after boot “self checkup”.

    The electronic chips used in the camera were common back in the days and shouldn’t just die like that. Don’t give in on it. If it is an electronic failure then it can be found and if nothing smells burnt then it is more a matter of time and persistence. The problem is the cramped space and puny sizes, one mistake with a screwdriver and you have made an irreparable mess of it…

    (BTW do you have an electronics background? It sure helps here.)

    • Kay says:

      Schematics would be a dream and yes I’m an engineer in electronics.

      The weird thing is as I said the PCB gets VCC from the connection on the top so there should be VCC on that cable as far as I could trace the traces (given there is voltage on the motor driver).
      Do you know what that bigger white round SMT thing is ? It looks like a fuse to me. (on your top pic the one on top)

      • jabcam says:

        Haha, yeah that white cylinder… It confused me too. My guess was also a fuse but mine read 0 ohms, IIRC, so it was ok.

        The vias on the PCB apparently can play a game but it would be strange if the battery power entered the PCB on several different places.

        I sketched a schematic for the first few components and believe the first ones after the red wire were voltage stabilizers and power distribution stuff. Anyway that lead me to concentrate on the red wire and its immediate vicinity. Thats how I found the broken via under the cap.

        Finding old SMD-components is a major hassle (do they reuse the component markings?).

        I’d love to get at go at it but if you also are in the electronics business you can manage equally well yourself:=) However if you feel desperate and have nothing to loose…

        I think I went through every page on the internet trying to find info about the hexar’s internals but found nothing at all really. I have had my eye open for broken Hexars on ebay now and then if not only just to write a proper schematic!

        Again, the very best of luck. It is a fantastic camera. I don’t often get excited over cameras nowadays but the Hexar has really stuck!

        Keep me updated, please!

      • Tibo Alberny says:

        Hi,
        My Hexar is dead as well 😦 !
        After disassembling, the white fuse seems busted (my meter says 1 ) . I can read 200CMX or 2000MX on it but im not sure. Do you have any idea what sort it would be ?

        Thx 🙂

      • jabcam says:

        A bit unclear here. What “1” does your meter say? Units? What is 200 CMX? It is yet not confirmed the white cylinder is a fuse, either way if it reads 1 ohm then it should be ok.

        I cannot answer in the thread so here goes:

        Tibo, thanks for the pictures! The letters are “2.00 (m)X” and as it seems to be connected to the processor via small capacitors I believe Kay below is correct: The cylinder must be a 2 MHz crystal (XTAL – which would explain the X also?) acting as the system clock for the board.

        I wish I could find a really dead one just for writing the schematic of the entire board, I am unwilling to disassemble my own working camera to the extent needed.

        Regarding your reading I have no camera to make the same measurements on. Perhaps another reader can?

        Oh, and the black test lead should go to the “COM” for common jack.

        Again, thanks for the pictures!

      • Kay says:

        2000MX could stand for 20.00MX and could be a ceramic resonator for the CPU clock

      • Tibo Alberny says:

        I took pictures :

        This is the white “fuse” :

        This is the reading i have on it with the battery and power on :

        The battery is ok and the contacts as well.
        Do you get a reading on the bottom red and black ?

      • Tibo Alberny says:

        Thanks for your reply.

        I’ve seen corrosion under the 2 blue capacitors. How would you clean it ? Should i replace the capacitors. I bought that Hexar dead for 20€ so i’m willing to dissamble it entirely to help map the electronics if i cant fix it. I have very limited experience in electronics but this can be a great common project 🙂

      • Ali Bosworth says:

        Tibo: from your picture it looks like you have a darkened trace leading up from the left capacitor. It looks very similar to mine. Once I noticed I saw a lot that looked like that and I am fairly sure that is the problem for me.

      • kay says:

        Measured the white thing .. frequency counter says 2MHz when the battery is plugged in 😉
        Funny: every time someone writes something here I pull my hexar out of the drawer with new hope. When I did so today I noticed the IR LED was illuminated when the battery is in and later did not anymore. I smelled electronic heat and noticed the little thing next to the display is brutal hot. I guess it’s a LDO well I could find a datasheet from Seiko saying it’s a voltage detector and DX marking means 3.3V.
        I added your fix to the cap anyway but honestly my PCB looked fine there.
        Damn I want that schematic.

  3. Ali Bosworth says:

    Thanks for your post.

    1) Do you have any tips for taking off the front plate(s)? I haven’t found anything online about this but it is clear from your first photo above that you have it off.

    2) Did you happen to notice any dark/splotchy traces in the flex boards? I’m wondering if I see one to the right of the rightmost capacitor in your photo, but it might just be the lighting.

    I have an AF with intermittent symptoms (Initially was just slow start up, graduated to long periods of not even starting). I ruled out any obvious switch issues under the top plate, and looking under the bottom plate I found what appeared to be corrosion on the negative terminals of the two caps your point out (did you notice that at all?), though no other signs of the capacitors themselves being bad. Under that main circuit is another flex board that wraps over one of the motors and has three SMD resistors on it, which are in close proximity to the corrosion on the capacitor terminals and show corrosion at their solder points (but measure OK), so I was hoping that swapping the caps might resolve my problems. Unfortunately when I went to do the swap the problem was not occurring, but then did occur during the process of swapping in new caps and is still occurring (total non functioning) so I think it is a bigger issue. However, I now notice many dark and splotchy traces in both boards down there. These are even in my old pictures of the area, so I didn’t cause them during my capacitor switch. I’m thinking some physical failure of the flex boards is allowed the traces to corrode and it seems like too big of a job to jump them all, especially considering it is likely to continue to worsen throughout the board.

    • jabcam says:

      Hello Ali!

      To get the front plate off you have to peel off the outer parts of the leatherette to get at a total of four (?) screws. There were two of them under the leatherette surrounding the battery comportment, the others were closer to the leatherette’s edges. Lift it and you will find them. I removed the left part of the plate too but that was not necessary.

      Regarding your splotchy traces. I believe that the solder joint went dead due to some corrosion and I imagine it came from a electrolytic capacitor leaking just at the legs of it. From what I saw it did not spread around the flexiboard (capillary forces could make this possible I imagine). In my case I could have replaced the cap if I had another of the same size, but in the end I opted to just put a jumper over the damaged board. I first tried heating the joint but that did not help. The flexiboard takes heat quite well by the way, I was afraid it would melt like Sellotape but it didn’t.

      It is too bad the service manual for the camera hasn’t appeared on the web. That would have helped a lot.

      Anyway good luck on your quest. It is a very fine camera so it is worth investing many hours in repairing it.

      Cheers!

  4. Nathan says:

    Hi!

    First of all, awesome work!!

    I have a Hexar AF that wouldn’t turn on. I reckon it has the same problem as yours did. Any chance I can send the camera off to you so you can check it out?

    I’d be more than grateful if you could. My email is [edited to prevent spam/jabcam]

    Thank you,

    Nathan

  5. AEG says:

    I recently acquired a dead Hexar AF (Rhodium) and found your site while trying to track down an approach to discerning the problem. I opened the camera and checked for current along the path you describe above: I have battery voltage to the point where your jumper is sourcing power (OK14), but at the right pin on the right capacitor, I see less than 0.5v. I have ground continuity all the way to the LB8620. I’m thinking this looks very similar to the problem you had on your camera – would you concur?

    I have limited electronics experience, but lots of camera repair experience. If indeed I have to solder a jumper I think I can manage it without too much difficulty. Would you say it is necessary to desolder the capacitor to clean the pins before attaching the jumper, or will it suffice to just attach the new wire as-is?

    Thanks for any clarification you can provide, and thanks for posting the DIY.

  6. John McCusker says:

    Could you share how you managed to remove the bottom plate? I’ve take the 5 screws out but it won’t budge from the corner where the film is….

    • jabcam says:

      Strange, don’t remember that was a problem. I loosened the two screws just now under the film compartment and the bottom plate moved accordingly. Have yours been glued into place? For full removal it is only the five screws if I remember correctly.

      • J McC says:

        made it a bit farther along, but stuck at how to get under the PCB where the two capacitors are. I have some clear erosion along the main trace on the outside of the board. Removed the top plate as well to see if I could unfold the PCB starting there, but with no luck. Any advice – thanks for the help thus far.

      • jabcam says:

        To unfold the PCB you also need to the remove the right front. There are two screws under the leatherette around the battery compartment and some more around the lens. Remove the leatherette completely to get a view. The PCB is screwed into place from the bottom with 2 (?) more small screws. You cannot reasonably easy remove the entire PCB but you can bend it enough to get access from below to desolder the caps. I feel like a dentist pushing in cotton pads here and there to fixate the PCB while soldering.

    • A Bosworth says:

      Are you sure it isn’t just that the rear door needs to be opened? And the battery compartment door removed?

      • J McC says:

        That was indeed it! I had a half-used roll of film in there – but gave up on that, and then my problem was solved. Next question though is if anyone has any tips on getting access to the underside of the PCB under the bottom plate – does one need to remove the leatherette and start taking the entire camera apart??

        I think I have the same problem around the capacitors – indeed the large outer trace looks to be mostly eroded and gone. The rest looks in tact so I have some hope that running a trace around the eroded section could fix it.

  7. Hi, my black Hexar AF just died as well as I went to a camera shop to buy a new battery for it. The shop keeper fumbled a bit with it, he could not open the battery compartment (I did not ask him to, but he just wanted to help and check the contacts). When he inserted the new battery the LCD turned on for a second and then it died. I noticed a little pin had broken of the lid, but I don’t think that is causing the problem. What do you recommend me to do? I am not the kind of person who owns a soldering iron, I know people who do, though. I really hope I can bring it back to life, it is such a wonderful camera…

    • jabcam says:

      There is no electrical connection on the lid so if you press down the battery there should be contact. Perhaps one of the metal contacts is broken off?

      • It’s still dead. I’ll open it up with assistance of a friend who knows more about wires and circuit boards than I do. I will get back when we have looked into to it. And thanks posting about resurrecting the Hexar 🙂

      • Hi, I have tried to insert the battery a couple of times over the last couple of days. Today something new happened. The camera turned on for perhaps 3-5 seconds and everything looked fine. Then it shut off again. The contacts looks clean but it seems like some sort of connection problem. Have you got advice?

  8. Tibo Alberny says:

    So i dug a little deeper.
    I found that one of the 2 capacitors has corrosion on the pins :

    And a few tracks are looking pretty dodgy


    I have no continuity between this point :

    and the positive pin of the right capacitor :

    Is it like what you experienced ? Is it where your bridge is ?
    Thx

    • jabcam says:

      Yup! This is pretty much the state of the two I have repaired. In my limited experience a resolder of the caps has been sufficient. Some cleansing of the tracks and also some jumper wires for bad printed copper was all that was needed.

    • Ali Bosworth says:

      Yes that is what mine looked like also, except i think i had more widespread black traces, not realistic for me to jump. And also it seems like even if I got them all the problem was spreading. I ended up buying a second broken unit which i think is broken differently and hopefully i can swap circuit boards, though it seems like a large job and complicated job. I hope a simple trace jump works for you!

    • kay says:

      yeah that is how mine looks like too, not the contacts but exactly the same black the track..
      I wonder if this is a damage thru too much current. It seems the track starts on the positive side of that other elco. can you confirm this? Reading here says no contact.. might be because of the burn
      My theory is that if the motor wasn’t moved in while the motor driver needs more power and thus burning away the positive supply tracks

      • Tibo Alberny says:

        Half of this track seems to be ok as i have continuity between those 2 points but then nothing to either pins of the capacitor. From what i can see in transparency i think it goes to the + but i cant be sure. I tried to remove the capacitor to check but failed so far :p

      • Tibo Alberny says:

        This is my wiring to far :

        but when i put the battery in , i’ve got smoke coming out of this point on the top …

        I tried resoldering the top on but i still got smoke here.
        Not so weird i guess as i dont know what im doing ^^

      • Tibo Alberny says:

        I removed my bridge (white wire) and now the screen is working. I guess that’s improvement ! But the screen displays BC even though i put a brand new battery tested 6,4V in it . It drains the power from the battery very quickly. The battery loses 0,2 V every 3 or 4 seconds.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s